Technischer Dienst: Probleme mit dem RSS-Feed?

Nichts ist schöner als sich Sonntagmorgens um die Technik zu kümmern… Aber es hilft ja nix: Etliche Leser haben mir per Mail mitgeteilt, dass sie Probleme mit dem RSS-Feed dieser Seite haben. Das kann ich leider nicht nachvollziehen, in meinem RSS-Reader (Netvibes, s. Screenshot oben) läuft es einwandfrei.

Damit wir das Problem eingrenzen können: Wer derzeit Probleme hat, den RSS-Feed von Augen geradeaus! zu bekommen, sollte bitte in den Kommentaren möglichst exakt benennen, was er nicht bekommt (den Feed für Einträge, den Feed für Kommentare, RSS oder Atom?; welcher Feedreader), damit da gegebenenfalls eine Abhilfe möglich ist.

9 Gedanken zu „Technischer Dienst: Probleme mit dem RSS-Feed?

  1. Ganz fix, bevor ich auf Arbeit entschwinde: Könnte mit den Problemen, die der Firefox aktuell hat (speziell im Add-On Bereich) zu tun haben: https://twitter.com/mozamo

    Hab leider gerade keine Zeit, ein paar Minuten Recherche reinzustecken.

  2. SpaRSS (Android) zeigt für Augen geradeaus folgenden Fehler an:
    „At line 213, column 45: not well-formed (invalid token)“

    Quelle:
    http://augengeradeaus.net/feed/

    Die betreffende Textstelle kommt im Eintrag zu „https://augengeradeaus.net/2019/05/wer-hat-die-kontrolle-in-afghanistan-die-daten-braucht-das-militaer-nicht/“ vor (Ausschnitt, UTF-8):

    „This quarter, RS formally notied SIGAR that“

    Statt eines „z“ (Bytewert 0x7a) erscheint ein Steuerzeichen (Bytewert 0x1f, Unit Separator).

    [Danke für den Hinweis. Da war in der Tat ein merkwürdiges Zeichen, habe das mal rausgenommen – aber ob das den Feed quasi lahmgelegt hat? T.W.]

  3. Ergänzung: Sollte im Originaltext wohl „notified“ heißen, in RSS und dem Artikeltext steht nur „noti\x1fd“. Der Browser bügelt es glatt („notied“), RSS-Reader stolpern ggf. über nicht XML-konforme Zeichen. Ich tippe auf einen Eingabefehler im Artikeltext, den WordPress dann automatisch in RSS einpflegt.

  4. @Jan: Mozilla hat verpennt (einmal mit Profis), ein Zertifikat für Addon-Signierung zu erneuern, weshalb nun fast alle Addons als nicht vertrauenswürdig automatisch deaktiviert wurden. Passend als Armag-Addon bezeichnet. Sollte hiermit zum Glück nix zu tun haben.

  5. @TW: Leider nein, im gleichen Zitatblock lauert noch ein Typo. Um nicht iterativ vorzugehen, hab ich mal w3.org drauf losgelassen.

    https://validator.w3.org/feed/check.cgi?url=http%3A%2F%2Faugengeradeaus.net%2Ffeed%2F

    „line 213, column 176: XML parsing error: :213:176: not well-formed (invalid token) [help]

    … government and insurgent control and inuence, expressed in a count of …“

    Diesmal ist es 0x1E (Record Separator).

    [Ah, wie im anderen Fall stammen die problematischen Zeichen von einem pdf auf einer Webseite, von der ich Texte rüberkopiert habe. Habe das jetzt auch geändert. Auf andere Dinge wie bestimmte Atribute oder Tags in embedded Tweets habe ich keinen Einfluss. T.W.]

  6. Die problematischen Zeichen sind eventuell Ligaturen, also Kombinationen aus zwei oder drei Buchstaben, die aus optischen Gründen zusammengezogen werden. Häufige Beispiele sind fi, ff und ft. Gelegentlich gibt es Produktionsprozesse für Dokumente, die typographisch so „gut“ sind, dass Ligaturen erzeugt werden. Leider ergibt das später oft Probleme bei der Weiterverwertung mit Copy&Paste – das war hier offenbar der Fall.

  7. Ich nutze Thunderbird. Der RSS-Feed funktioniert schon seit einigen Tagen nicht mehr. Dies ist der einzige Feed, der nicht funktioniert. Löschen und Neueinrichtung helfen nicht. Eine Fehlermeldung kommt nicht, der Feed wird offensichtlich nicht als Feed erkannt.

  8. Reader „Newsify“.
    Probleme gibt es beim Kommentare-Feed. Es werden keine Kommentare gefunden/angezeigt. Er erfolgt keine Fehlermeldung.

Kommentare sind geschlossen.